Excel’de Hücre İçindeki İsimleri Kısaltmak



Excel’de bazı hücrelerimiz var Biz bu A sütunundaki isimleri D sütununda olduğu gibi ismin baş harfi + “.” + soyad şeklinde görüntülemek istiyoruz. Elimizde ad-soyad verisi bol olduğundan bu sonucu

alabileceğimiz formül veya formüller var mıdır? (İsimlerin hep 2 kelime olduğunu varsayiyoruz)

Cözüm: A1 hücresinde isim var ise, B1 hücresine aşağıdaki formülü uygulayin isimlerin kisaltildigini göreceksiniz

=CONCATENATE(LEFT(A1;1);". ";MID(A1;SEARCH(" ";A1)+1;SEARCH(" ";A1)))

Örnegi aşağıdaki resim:

Hücredeki rakamları saysın


varsayalim elinizde binlerce satirdan olusan veriler var ve bunlarin bazilari rakam bazilari harf ve size de sadece rakamlar in kac adet olduğu gerekli , bunu tek tek saymak herhalde aylar alir bu nedenle excel basit bir formül sunuyor =COUNT , mesela yukaridaki formül söyledir =SAY(A2:H2)

=COUNT(A2:H2)

peki olayi birazcik daha gelistirelim , örneğin A1 ile A100 arasında 0 ile 200 arası sayılardan oluşan bir dizi var. biz bu dizi içerisinde kaç tane 5 sayısının olduğunu öğrenmek istiyoruz. ama 55 15 52 gibi hatta 105 gibi sayıları saymamamsini sadece 5 sayısını saymasini istiyorsak :

=COUNTIF(A1:A100;"=5")

yada

=COUNTIF(A1:A100;5)

Türkcesi

=EĞERSAY(A1:A100;"=5")

IF kullanimina bir örnek


Sorun: Eğer A1 sutünunda bulunan tarih B1’den büyükse(yeniyse) c sutünuna “STOKTA”, küçükse “BİTMİŞ” , yazmasini istiyorum bunu hangi formulle otomatik olarak yaptirtabilirim

Cözüm: aşağıdaki formülü kullandiginizda istediğiniz gerceklesecektir

=IF(ISERROR(IF(DAYS360(B1;A1;TRUE)>0;"Stokta";"Bitmiş"));"?";IF(DAYS360(B1;A1;TRUE)>0;"Stokta";"Bitmiş"))

Yorum Ekle

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Captcha