Excelde en yüksek değerin karşılığını bulun


Excelde en yüksen değer
Excel ile ilgili sizlerden bazı istek ve sorular alıyoruz bunlardan vaktimizi almayacak olanlarını çözüme kavuşturup konu olarak açıyoruz , geçenlerde bir takipçimiz şu şekilde bir soru iletti


; Elimde gün içerisinde değerler girilmiş 1000 adet satırdan oluşan bir excel tablosu var Tablo iki sütundan oluşuyor , bunlardan ilkinde Saatler , ikinci sütunda ise yük değerleri bulunmaktadır. Ben bu tabloda en yüksek yük değerinin hangi saatte oluştuğunu veren formülü nasıl oluşturabilirim. Bu örnek gündelik hayatta birçok yerde kullanılabilir mesela Meteorolojide günlük olarak girilen ısı değerleri tablosu veya Döviz kurları tablosu hatta bir hastanın saatlik tansiyon değerli tablosu bile olabilir. Gelin isterseniz soruyu örnek olarak oluşturduğumuz bir tablo üzerinden çözmeye çalışalım.

En yüksek değeri veren excel formülü

Excelde bir soruna çözüm ararken farkı formüllerden faydalanılabilir , benim burada kolayıma gelen DÜŞEYARA (VLOOKUP) ve MAK (MAX) formüllerini birlikte kullanmaktır.Gelelim adımlarına;

1. Saatlerin yeraldığı Sütunu olduğu gibi Yük Sütununun sağına kopyalayın.

Excele düşeyara sütunu

2. Yük sütununun alt kısmına aşağıdaki formülü uygulayın (ilk formül türkçe , ikincisi ingilizce Excel kullananlar içindir)

=MAK(B2:B22)
=MAX(B2:B22)

Sizdeki sutünün başlangıç ve bitiş hücreleri farklı olabilir bu kısma dikkat etmenizde fayda var.

3. Bir sonraki adım olarak Saatler sütununun altına aşağıdaki formülü uygulayın

=DÜŞEYARA(B23;B2:C22;2;YANLIŞ)
=VLOOKUP(B23;B2:C22;2;;FALSE)

Aşağıdaki resimde Düşeyara formülü oluşturulurken kullanılan parametreleri görmektesiniz.

Düşeyara formülü

Saatler sütununu yük sütununun sağına kopyalamadan düşeyara formülünden faydalanamazdık bu sebeple bu işleme gerek duyduk. Neticede önce Yük sütunundaki en yüksek değeri buldurduk ardından bu değere karşılık gelen saat i Düşey ara formülü yardımı ile karşısına yazdırdık.

excelde en yüksek değer bulundu

Peki aynı işlemi DÜŞEYARA yerine farklı bir Formülle yapabilirmiydik derseniz evet , ARA formülü de aynı işi yapabilirdi mesela aşağıdaki formülde aynı sonucu verecekti.

=ARA(F2;B2:C22)

Yine önce kaçıncı formülün kullanarak Hangi satırda olduğunu buldurtup ardından İNDİS ve KAÇINCI formülerinin birlikte kullanımı ile (Aşağıdaki formül)

=İNDİS($A$1:$A$22;KAÇINCI(F12;$B$1:$B$22;0))

İstediğimiz yük değerinin hangi saate karşılık geldiğini kolayca bulabilecektik.

En yüksek değer formülleri

Görüldüğü üzere Excelde bir sorunu çözmek için çok farklı yöntemler kullanılabilmektedir. Örnek tabloyu aşağıdaki indirme linkinden edinebilirsiniz.

- vbs ile boş Word veya Excel belgesi açalım Burada

- Excel de belirli bir sütuna göre sıralama yaptırın Burada

- Excel otomatik olarak belirli bir çalışma kitabını açsın Burada

- Excel de Ekle ve Sil ikonları silik çözümü Burada

- Excel de bugün formülü nasıl kullanılır Burada

- Excelde klavye yön tuşları çalışmaz oldu Burada

- Office uygulamalarını Güvenli Mod da başlatın Burada

- Excel de hücrelerdeki yazıları birleştirelim / bölelim Burada

- Excel veya Word da Pano nasıl temizlenir Burada

- EXCEL de dolu veya boş hücreleri saydıralım Burada


4 Yorum Var

Yorum Ekle

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Captcha