Excel de akıllı numaralandırma


excel akilli numaralama

Excel iş dünyasının vazgeçilmezlerinden çünkü çalışanların işlerini oldukça kolaylaştıran birçok özelliği bünyesinde barındırıyor , otomatik grafik çiziminden tutunda ileri hesaplama yöntemlerine

kadar excel ile yapılamayacak şey yok , varsayalım elimize bir excel sayfası verildi ve veri olan satırları numaralamamız istendi , eğer satırlar alt alta ise (Arada boşluk yok) bunu kolayca yapabilirsiniz ; veri olan satırın başına 1 sonrakine 2 yazar ve hücrenin bittiği yerden tutar aşağıya doğru sürükleriz (Aşağıdaki resim)

Excelde otoatik sıralama

Böylece excel sürüklemeyi bıraktığımız yere kadar numaralandırmayı otoamatik olarak yapacaktır , Peki ya satırlar sıralı değilse ? mesela ilk satırda veri var sonraki iki satırda veri yok , sonrakinde var …. (Aşağıdaki resim)

excel akilli sıralama

Bu üstteki tablonun binlerce satır içeren bir excel sayfası olduğunu varsayın ve şefiniz bunu en kısa sürede istiyor , ilaveten satır boşluk düzenini de bozmamanızı özellikle tembihledi , elbette sorunun farklı çözümleri olabilir fakat olası en optimum çözümlerden biri excele : eğer veri görürsen numaralandırma yap demektir, bu nasıl olacak derseniz haliyle aşağıdaki formülle (verilerin B1 den başladığı varsayılmıştır)
İngilizce excel:

=IF(NOT(ISBLANK(B1));COUNTA($B$1:B1);"")

Türkçe Excel:

=EĞER(DEĞİL(EBOŞSA(B1));BAĞ_DEĞ_DOLU_SAY($B$1:B1);"")

Bu üstteki formülü ilk hücreden itibaren aşağıya doğru en sona kadar (yada verinin bittiği yere kadar) kopyalayın o otomatik olarak veri olan yerlerde numaralandırma yapacak , olmayan hücreleri boş bırakacaktır.
Not: Ben ingilizce Excel kullandığım için bu konuyu ilk formülü deneyerek yazdım fakat yüksek ihtimalle türkçesinde bir sıkıntı yoktur Peki siz , Almanca veya başka dillerden birinde olan excel kullanıyorsanız ne yapacaksınız ? , Kolayı var benim ingilizce formülü türkçeleştirirken kullandığım web sayfasından faydalanabilirsiniz :

excel formüllerini başka dillere çevir

Böylece excel formüllerini istediğiniz ülke diline çevirip O dildeki excellerde kullanabilirsiniz , bu sayfayı oluşturan arkadaşı tebrik ediyorum Anasayfası



13 Yorum Var

Yorum Ekle

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

CAPTCHA